Back to overview
Downtime

TitanX is currently experiencing an interruption in service. (app.titanx.io & trust.titanx.io)

Nov 18 at 07:07am EST
Affected services
app.titanx.io
trust.titanx.io

Resolved
Nov 18 at 10:33am EST

Platform Accessibility Issue Due to Cloudflare Outage - November 18, 2025

Description

On November 18, 2025 at approximately 6:07 AM EST, the TitanX platform experienced intermittent accessibility issues due to a global Cloudflare service degradation affecting our infrastructure provider.

Root Cause:
Cloudflare, a critical infrastructure provider used by TitanX and thousands of other applications worldwide, experienced internal service degradation that impacted their global network. This caused downstream effects on app.titanx.io and our database infrastructure (Supabase), resulting in failed or delayed requests.

Timeline:
- Nov 18, 6:07 AM EST - Cloudflare reported global service degradation; TitanX platform began experiencing intermittent failures
- Nov 18, 6:07 AM - 9:42 AM EST - Cloudflare worked on remediation; TitanX experienced degraded performance with intermittent errors
- Nov 18, 9:42 AM EST - Cloudflare implemented a fix and reported the incident resolved
- Nov 18, 10:39 AM EST - TitanX platform confirmed fully operational

Impact:
- Platform was intermittently inaccessible or experienced degraded performance for approximately 3.5 hours
- Users may have experienced failed login attempts or slow page loads
- List processing and submissions were delayed during the outage window
- Trust Center (trust.titanx.io) was also affected

Resolution:
Cloudflare successfully implemented a fix to resolve their service degradation. The TitanX platform is now fully operational and stable. All delayed list processing has been completed, with lists successfully synced to integrated systems.

Third-Party Status:
Cloudflare's incident status and updates were tracked at cloudflarestatus.com throughout the event.

If you continue to experience any issues accessing the platform, please contact support@titanx.io for assistance.

Created
Nov 18 at 07:07am EST

Platform Accessibility Issue Due to Cloudflare Outage - November 18, 2025

Description

The TitanX platform is currently experiencing intermittent accessibility issues due to a global Cloudflare service degradation affecting our infrastructure provider.

Root Cause:
Cloudflare, a critical infrastructure provider used by TitanX and thousands of other applications worldwide, is experiencing internal service degradation impacting their global network. This is causing downstream effects on app.titanx.io and our database infrastructure (Supabase), resulting in failed or delayed requests.

Current Status:
- Cloudflare reported global service degradation at 6:07 AM EST
- TitanX platform is experiencing intermittent failures and degraded performance
- Users may experience failed login attempts or slow page loads
- List processing and submissions may be delayed

What We're Doing:
Our engineering team is actively monitoring the situation and tracking Cloudflare's remediation efforts. We are prepared to take additional measures as needed once Cloudflare services stabilize.

Third-Party Status:
Cloudflare's incident status and real-time updates can be tracked at cloudflarestatus.com

Next Steps:
We will provide updates as the situation progresses and Cloudflare works toward resolution. If you need urgent list submission assistance and cannot access the platform, please send your list to support@titanx.io.

We apologize for the disruption and appreciate your patience as we work through this third-party service issue.