Back to overview
Downtime

TitanX is currently experiencing an interruption in service. (app.titanx.io)

Nov 16 at 09:15pm EST
Affected services
app.titanx.io

Resolved
Nov 17 at 09:22am EST

Platform Processing Issue - November 16-17, 2025

Description

On November 16, 2025 at approximately 9:15 PM ET, the TitanX platform experienced a service disruption caused by a processing issue that affected platform availability.

Root Cause:
An excessive number of processing events appeared in our queuing system, which degraded application performance and eventually rendered the platform unusable. This issue was initiated during the processing of a list submission.

Timeline:
- Nov 16, 9:15 PM EST - Issue began during list processing
- Nov 17, 9:22 AM EST - Platform restored to operational status with hotfix deployment

Impact:
- Platform was unavailable or severely degraded for approximately 12 hours
- Customer list submissions and processing were affected during this period
- Some jobs submitted during the incident window required reprocessing

Resolution:
Our engineering team deployed a hotfix to address the queuing issue and restore platform functionality. The platform is now operational and stable. We are actively monitoring system performance and reprocessing any affected jobs to ensure data integrity.

Preventive Measures:
We are conducting a thorough investigation to implement additional safeguards and prevent similar issues from recurring.

We apologize for any disruption this may have caused to your operations.

Created
Nov 16 at 09:15pm EST

Platform Processing Issue - November 16-17, 2025

Description

On November 16, 2025 at approximately 9:15 PM EST, the TitanX platform experienced a service disruption caused by a processing issue that affected platform availability.

Root Cause:
An excessive number of processing events appeared in our queuing system, which degraded application performance and eventually rendered the platform unusable. This issue was initiated during the processing of a list submission.

Timeline:
- Nov 16, 9:15 PM EST - Issue began during list processing

Impact:
- Platform access is currently severely degraded
- Customer list submissions and processing may be affected during this period
- Some jobs submitted during the incident window may require reprocessing. TitanX will reach out to impacted clients as necessary.

We apologize for any disruption this may have caused to your operations.