Back to overview
Maintenance
TitanX is undergoing maintenance.
Nov 23 at 12:00pm EST
–
Nov 23 at 12:49pm EST
Affected services
app.titanx.io
Resolved
Nov 23 at 12:49pm EST
Maintenance is completed.
Affected services
Created
Nov 23 at 12:00pm EST
TitanX is will be undergoing maintenance on Sunday, November 23rd at 12:00PM EST. The website will be available as soon as maintenance activities complete.
Affected services