Back to overview
Resolved
Unexpected Downtime
Jul 14, 2026 at 11:14pm UTC
Affected services
app.titanx.io
Resolved
Jul 14, 2026 at 11:45pm UTC
Issue is resolved
Affected services
Created
Jul 14, 2026 at 11:14pm UTC
We have unexpected downtime due to a change in the database. This is actively being worked on.
Affected services