Back to overview
Resolved

Scheduled Maintenance — Saturday, August 8

Aug 8, 2026 at 2:00pm UTC  –  Aug 8, 2026 at 6:48pm UTC
Affected services
app.titanx.io

Resolved
Aug 8, 2026 at 6:48pm UTC

Site Maintenance has been completed. The maintenance page has been removed and the TitanX platform is now accessible again.

Updated
Aug 8, 2026 at 6:48pm UTC

Maintenance ended

Created
Aug 8, 2026 at 2:00pm UTC

We're performing scheduled maintenance on our systems on Saturday, August 8.

We've built in a longer window than we expect to need, so this notice may stay up for up to 24 hours. In practice, we expect the work to take a few hours, and we'll take this notice down as soon as it's done.

During this window, parts of TitanX may be intermittently or fully unavailable. We'd rather give ourselves room to do this safely than rush it.

This is part of a series of improvements we're rolling out over the next few months. Nothing about how you use TitanX today is changing — once this maintenance wraps up, everything will work exactly as it does now.

You don't need to do anything on your end. We'll update this page as soon as the maintenance is complete.